Results 1 to 7 of 7

Thread: Access to path denied

  1. #1
    Join Date
    Sep 2007
    Posts
    6

    Access to path denied

    What do I do about this? It just stareed happening. I use Windows 7

    Application: Living Cookbook 2.0.53
    Message: Access to the path 'C:\Users\Harold\AppData\Local\Radium Technologies\Living Cookbook\2.0\User Options\UserOptions.xml' is denied.

    Stack Trace: at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
    at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy)
    at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share)
    at System.Xml.XmlTextWriter..ctor(String filename, Encoding encoding)
    at System.Xml.XmlDocument.Save(String filename)
    at Radium.Services.x25bf63c9397182a7.x88add1ce934ff38 4(String x0eecbd535a5d7da5, String xe98203f0d0d60092, String xb1c51c1d5b972ad0, String xfe1155bd9010ca77)

  2. #2
    Join Date
    Sep 2002
    Location
    Winthrop, NY
    Posts
    31,321
    Hi,

    That error suggests that Living Cookbook no longer has read/write access to files in the C:\Users\Harold\AppData\Local\Radium Technologies\Living Cookbook\2.0\User Options\ folder. Have you recently changed any of your Windows user account settings?

    Lee

  3. #3
    Join Date
    Sep 2007
    Posts
    6
    Not intentionally. Bit if so, how can I change it back?

    Thanks

  4. #4
    Join Date
    Oct 2009
    Location
    Winthrop, NY
    Posts
    5,751
    Hi there,

    Try the following:

    1) Launch Windows Explorer.

    2) Choose Folder Options from the Tools menu.

    3) Click the View tab and choose Show Hidden Files and Folders.

    4) Click OK.

    5) In the Windows explorer browse to c:\ProgramData\Radium Technologies\Living Cookbook\2.0

    6) Right-click the 2.0 folder and choose Properties.

    7) Click the Security tab.

    8) Find your user group (are you signed in to Windows as a User? Authenticated User? Administrator?) and select it.

    9) Scroll down to Write in the Permissions for Users section.

    10) Put a check in Allow for Write.

    11) Click OK.

    Then try to duplicate the error in Living Cookbook. Let me know how you fare.

    Geoff
    Follow us on Twitter: @livingcookbook

  5. #5
    Join Date
    Sep 2007
    Posts
    6
    Sorry, that did'nt work. Any other suggestions?

  6. #6
    Join Date
    Sep 2007
    Posts
    6

    Path denied

    Still getting this message. What now?

    Application: Living Cookbook 2.0.53
    Message: Access to the path 'C:\Users\Harold\AppData\Local\Radium Technologies\Living Cookbook\2.0\User Options\UserOptions.xml' is denied.

    Stack Trace: at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
    at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy)
    at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share)
    at System.Xml.XmlTextWriter..ctor(String filename, Encoding encoding)
    at System.Xml.XmlDocument.Save(String filename)
    at Radium.Services.x25bf63c9397182a7.x88add1ce934ff38 4(String x0eecbd535a5d7da5, String xe98203f0d0d60092, String xb1c51c1d5b972ad0, String xfe1155bd9010ca77)

  7. #7
    Join Date
    Oct 2009
    Location
    Winthrop, NY
    Posts
    5,751
    Hello,

    This is a Windows error, you do not have sufficient rights to modify your useroptions.xml file. If the following does not work, I recommend contacting Windows support to see why that is:

    Try the following:

    1) Launch Windows Explorer.

    2) Choose Folder Options from the Tools menu.

    3) Click the View tab and choose Show Hidden Files and Folders.

    4) Click OK.

    5) In the Windows explorer browse to C:\Users\Harold\AppData\Local\Radium Technologies\Living Cookbook\2.0

    6) Right-click the User Options folder and choose Properties.

    7) Click the Security tab.

    8) Find your user group (are you signed in to Windows as a User? Authenticated User? Administrator?) and select it.

    9) Scroll down to Write in the Permissions for Users section.

    10) Put a check in Allow for Write.

    11) Click OK.

    Then try to duplicate the error in Living Cookbook. As you've already done this for the containing folder, this is more in the interest of being thorough that anything. I expect that you'll need to involve Microsoft support for assistance with this permissions issue.

    Geoff
    Follow us on Twitter: @livingcookbook

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •